Sign in through GitHub

RailsCasts Pro episodes are now free!

Learn more or hide this

Brian Bailey's Profile

GitHub User: BrianBailey

Comments by Brian Bailey

Avatar

Hello migane,

Do you have any updated information on highcharts as this comment was made 3+ years ago? Thank you, BBa

Avatar

*** very frustrated... want to use this and it is now feedjira and these issues are all over the internet with no solutions>>> please help... thanks

$ gem install feedjira
Temporarily enhancing PATH to include DevKit...
Building native extensions. This could take a while...
ERROR: Error installing feedjira:
ERROR: Failed to build gem native extension.

c:/RailsInstaller/Ruby2.0.0/bin/ruby.exe -r ./siteconf20150131-33384-bj8eh2.rb extconf.rb

checking for curl-config... no
checking for main() in -lcurl... no
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers. Check the mkmf.log file for more details. You may
need configuration options.

Provided configuration options:
--with-opt-dir
--without-opt-dir
--with-opt-include
--without-opt-include=${opt-dir}/include
--with-opt-lib
--without-opt-lib=${opt-dir}/lib
--with-make-prog
--without-make-prog
--srcdir=.
--curdir
--ruby=c:/RailsInstaller/Ruby2.0.0/bin/ruby
--with-curl-dir
--without-curl-dir
--with-curl-include
--without-curl-include=${curl-dir}/include
--with-curl-lib
--without-curl-lib=${curl-dir}/
--with-curllib
--without-curllib
extconf.rb:18:in `': Can't find libcurl or curl/curl.h (RuntimeError)

Try passing --with-curl-dir or --with-curl-lib and --with-curl-include
options to extconf.

extconf failed, exit code 1

Gem files will remain installed in c:/RailsInstaller/Ruby2.0.0/lib/ruby/gems/2.0.0/gems/curb-0.8.6 for inspection.
Results logged to c:/RailsInstaller/Ruby2.0.0/lib/ruby/gems/2.0.0/extensions/x86-mingw32/2.0.0/curb-0.8.6/gem_make.