Sign in through GitHub

Please read for an updated status on RailsCasts:

Learn more or hide this

strongwave's Profile

GitHub User: strongwave

Comments by strongwave

Avatar

This is what happened when I try to install it in Rails 3.0.7 and Ruby 1.9.1

$ rails g client_side_validations:install
/usr/local/lib/ruby/gems/1.9.1/gems/execjs-0.3.3/lib/execjs.rb:32:in runtime': Could not find a JavaScript runtime. See https://github.com/sstephenson/execjs for a list of available runtimes. (ExecJS::RuntimeError)
from /usr/local/lib/ruby/gems/1.9.1/gems/execjs-0.3.3/lib/execjs.rb:44:in
module:ExecJS'
from /usr/local/lib/ruby/gems/1.9.1/gems/execjs-0.3.3/lib/execjs.rb:3:in <top (required)>'
from /usr/local/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in
require'
from /usr/local/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee_script.rb:1:in <top (required)>'
from /usr/local/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee-script.rb:1:in
require'
from /usr/local/lib/ruby/gems/1.9.1/gems/coffee-script-2.2.0/lib/coffee-script.rb:1:in <top (required)>'
from /usr/local/lib/ruby/gems/1.9.1/gems/bundler-1.0.13/lib/bundler/runtime.rb:68:in
require'
from /usr/local/lib/ruby/gems/1.9.1/gems/bundler-1.0.13/lib/bundler/runtime.rb:68:in block (2 levels) in require'
from /usr/local/lib/ruby/gems/1.9.1/gems/bundler-1.0.13/lib/bundler/runtime.rb:66:in
each'
from /usr/local/lib/ruby/gems/1.9.1/gems/bundler-1.0.13/lib/bundler/runtime.rb:66:in block in require'
from /usr/local/lib/ruby/gems/1.9.1/gems/bundler-1.0.13/lib/bundler/runtime.rb:55:in
each'
from /usr/local/lib/ruby/gems/1.9.1/gems/bundler-1.0.13/lib/bundler/runtime.rb:55:in require'
from /usr/local/lib/ruby/gems/1.9.1/gems/bundler-1.0.13/lib/bundler.rb:120:in
require'
from /home/liboc/code-depot/qa-reg/TRAP/trunk/config/application.rb:7:in <top (required)>'
from /usr/local/lib/ruby/gems/1.9.1/gems/railties-3.0.7/lib/rails/commands.rb:15:in
require'
from /usr/local/lib/ruby/gems/1.9.1/gems/railties-3.0.7/lib/rails/commands.rb:15:in <top (required)>'
from script/rails:6:in
require'
from script/rails:6:in `'