Sign in through GitHub

Please read for an updated status on RailsCasts:

Learn more or hide this

David Douglas's Profile

GitHub User: ddd1600

Site: http://www.valueoutlook.com

Comments by David Douglas

Avatar

I got this error because my VPS server had installed Rails 3.2.8 when my app was running Rails 3.2.6.

Definitely check your Gemfile and your database.yml file (of course). The problem here is clearly stated---Rails is not communicating with your database specifically due to an adapter (aka gem)

Avatar

I'm getting a

failed: "sh -c 'cd /home/deployer/apps/angel_list_api_research/releases/20120827050009 && bundle install --gemfile /home/deployer/apps/angel_list_api_research/releases/20120827050009/Gemfile --path /home/deployer/apps/angel_list_api_research/shared/bundle --deployment --quiet --without development test'" on 198.58.96.39

Has anyone any idea what this is trying to tell me?

Avatar

This did not fix my problem :( Do I need to restart my postgre server? Trying now. Will report.

**Back: restarting didn't work, the apt-get thing did that anyway. Rails required version 9.1 (TIMELY--THIS WILL CHANGE. Give rails what it asks for in the error message.). I installed the one listed on the github site (9.0) and it still didn't work. Then, like Mrs. Griswald., I tried sudo apt-get install postgresql-contrib-9.1 instead of sudo apt-get install postgresql-contrib-9.0 and walah, problem solved. Back to the other problem. :)